Coastal Fishing Forums: AllCoast banner
1 - 3 of 3 Posts

· Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
New rebuilt carburetor "BUT" need please.

Left Sun Set going 5 knots, got to open water,slowly moved up to 8knots fine,moved up to 14 knots for about 200 feet than crapped out, back to neutral, runs fine, going down Sat to check it out,any suggestions, what should I be looking for. New timing belt plugs plug wires new fuel filter, the big one, water/sep rotor & cap Only happens under load, pushing water. Solex down draft 1 barrel, 4 banger elect fuel pump works fine. Thank you for any help. Frank

This post edited by wormguy 12/06/2013
 

· Registered
Joined
·
47 Posts
re: New rebuilt carburetor "BUT" need please.

I have had a problem with the gas tank "anti-siphon" valve on 3 different boats I have owned. It looks like an male air fitting mounted on the pick-up of the tank. There is a ball bearing check valve inside which is easily disrupted by any type of debris. You can remove it and replace it temporarily with a hose barb and see if it solves your problem. Fine at idle and dying after a high speed run are the symptoms of this restriction. Good luck. T
 

· Registered
Joined
·
69 Posts
Discussion Starter · #3 ·
re: New rebuilt carburetor "BUT" need please.

Thank You for you help.
I will check that out.
I have a mechanical fuel pump and a elect pump in front of the mechanical pump,a boat shop( Boat Works)said a fuel pump diaphragm
can DETERIORATE and small pieces can screws things up, to much or not enough gas,SO I will run the gas line from the elect fuel pump straight
to the carburetor, and bypass the mechanical.
Knot on wood.Thanks
Frank
Mold Inspector.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top